Uploaded image for project: 'Rust Driver'
  1. Rust Driver
  2. RUST-1373

Convert SDAM integration spec tests to the unified test format

    • Type: Icon: Task Task
    • Resolution: Fixed
    • Priority: Icon: Unknown Unknown
    • 2.4.0
    • Affects Version/s: None
    • Component/s: None
    • Labels:
    • Hide

      DRIVERS-2366:
      Drivers will need to update their unified test format runner to support the new entities and operations required for these tests (schema version 1.10), update their SDAM integration test implementation to use the unified test format runner, and sync the JSON/YAML tests to https://github.com/mongodb/specifications/commit/b1a3fdd46a0c7797557215a0804a2c3b96b3be94. The old integration JSON/YML files from the integration directory can be removed.

      Note that drivers will also need to implement support for the changes made in the unified format's schema version 1.9, specifically the createEntities operation.

      Show
      DRIVERS-2366 : Drivers will need to update their unified test format runner to support the new entities and operations required for these tests ( schema version 1.10 ), update their SDAM integration test implementation to use the unified test format runner, and sync the JSON/YAML tests to https://github.com/mongodb/specifications/commit/b1a3fdd46a0c7797557215a0804a2c3b96b3be94 . The old integration JSON/YML files from the integration directory can be removed. Note that drivers will also need to implement support for the changes made in the unified format's schema version 1.9, specifically the createEntities operation.

      This ticket was split from DRIVERS-2366, please see that ticket for a detailed description.

            Assignee:
            patrick.freed@mongodb.com Patrick Freed
            Reporter:
            dbeng-pm-bot PM Bot
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved:

                Error rendering 'slack.nextup.jira:slack-integration-plus'. Please contact your Jira administrators.