Uploaded image for project: 'Rust Driver'
  1. Rust Driver
  2. RUST-1669

Add serde_with 3.x integration

    • Type: Icon: Improvement Improvement
    • Resolution: Fixed
    • Priority: Icon: Minor - P4 Minor - P4
    • bson-2.7.0
    • Affects Version/s: None
    • Component/s: None
    • Labels:

      We have optional integration with version 1.x of the serde_with library; it's up to 3.x now, so we should add helpers for the newer version (and probably remove the older ones when we do a major version bump).

      We should also consider when picking up this ticket as to what we want to do for the 3.0 driver. Deprecate this or use feature flags?

            Assignee:
            drshika.asher@mongodb.com Drshika Asher (Inactive)
            Reporter:
            abraham.egnor@mongodb.com Abraham Egnor
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Created:
              Updated:
              Resolved: