Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-10240

text query/command does not yield properly

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Duplicate
    • None
    • None
    • Text Search
    • None
    • ALL

    Description

      I am inserting ~ 1k documents per second and when issuing a "text" command on the the same collection, the inserts stop and everything appears to lock. Mongostat also locked. You can see the gap in results below while the query is running. The results skip from 12:41:18 to 12:41:46 while it waits for the query to run.

        1161     *0     *0     *0       0  1163|0       0   168g   339g  10.4g    447    .:68.6%          0       0|1     0|1   408k    99k     4   12:41:17
        1161     *0     *0     *0       0  1163|0       0   168g   339g  10.4g    455    .:68.1%          0       0|1     0|1   408k    99k     4   12:41:18
         720     *0     *0     *0       0   724|0       0   168g   339g  11.2g    277   .:136.2%          0       1|0     1|0   253k    63k     4   12:41:46
        1147      3     *0     *0       0  1153|0       0   168g   339g  10.9g    438  test:2.7%          0       0|1     0|1   404k   127k     4   12:41:47
        1155     *0     *0     *0       0  1157|0       0   168g   339g  10.9g    439    .:76.2%          0       0|1     0|1   406k    99k     4   12:41:48
        1203     *0     *0     *0       0  1206|0       0   168g   339g  10.9g    453    .:68.2%          0       0|1     0|1   423k   103k     4   12:41:50

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              rgnitz Ryan Nitz
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: