Rename isLoadBalancerPort to also mention that it checks the proxy protocol port

XMLWordPrintableJSON

    • Type: Improvement
    • Resolution: Unresolved
    • Priority: Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • Networking & Observability
    • None
    • 3
    • None
    • None
    • None
    • None
    • None
    • None
    • None

      Right now, we only refer to a port that needs to check for the proxy protocol as the "load balancer port" throughout our codebase (outside of mongod_main where we parse the proxyPort server parameter), even though it may also be referring to the proxyPort. This leads to confusion when reading the code. Improve the naming here to make it clearer that this actually checks for the load balancer port on mongos and the proxy port on mongod.

              Assignee:
              Unassigned
              Reporter:
              Erin McNulty
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Created:
                Updated: