Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-11555

Deprecate addUser shell helper in favor of createUser helper

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.4
    • Component/s: Security, Shell
    • Labels:
      None
    • Backwards Compatibility:
      Minor Change
    • Operating System:
      ALL

      Description

      Currently the shell helpers are called addUser and addRole, but the commands they use are called createUser and createRole. We should make these names consistent.

      While addUser is what we had in the past, I think createUser is the better name as it's more standard in databases, and more consistent with other creation operations in the system, like createCollection and createIndex.

      Also, by moving away from addUser we can change the arguments so that write concern is passed to createUser as an object rather than having "numReplicatedTo" and "timeout" fields.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                spencer T Brody
                Reporter:
                spencer T Brody
                Participants:
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: