Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-12156

Don't allow authSchemaUpgrade to proceed if there appear to be pre-2.6 processes running in the cluster

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 2.5.5
    • Security
    • ALL

    Description

      this would protect against cases where old processes are running and continue to create/modify old schema user docs.
      it could try connecting to other mongos to check their version, and return error if any old process is found.

      Attachments

        Issue Links

          Activity

            People

              schwerin@mongodb.com Andy Schwerin
              mikeo@mongodb.com Michael O'Brien
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: