ExportXMLWordPrintableJSON

    • Type: Task
    • Resolution: Fixed
    • Priority: Major - P3
    • 9.0.0-rc1
    • Affects Version/s: None
    • Component/s: None
    • None
    • Catalog and Routing
    • Fully Compatible
    • CAR Team 2026-07-06, CAR Team 2026-07-20
    • 200
    • đŸŸ¥ DDL
    • None
    • None
    • None
    • None
    • None
    • None

      With the Authoritative Shards program, introduced in v9.0, a shard’s catalog may no longer contain chunks that the shard does not currently own. However, to serve snapshot reads, a shard must retain information about chunks it owned in the past when that historical information is still needed to target point-in-time reads.

      Before v9.0, each shard’s catalog contained all chunks for a sharded collection. As a result, there was no additional complexity associated with retaining historical ownership information in the shard catalog for point-in-time reads.

      In v9.0, chunk migrations can remove this historical ownership information even when it is still required for point-in-time reads. To prevent that from happening, moveChunk and moveRange operations should fail with a ConflictingOperationInProgress error if the migration would remove ownership history that is still required.

      The same command should succeed once the snapshot history window, defined by minSnapshotHistoryWindowInSeconds, has elapsed.

      Important: Note that this error will never be hit in a cluster where orphanCleanupDelaySecs is higher than minSnapshotHistoryWindowInSeconds.

            Assignee:
            Silvia Surroca
            Reporter:
            Silvia Surroca
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Created:
              Updated:
              Resolved: