ExportXMLWordPrintableJSON

    • Type: Improvement
    • Resolution: Unresolved
    • Priority: Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • None
    • Query Execution
    • None
    • None
    • None
    • None
    • None
    • None
    • None

      Improve ChangeStreamHistoryLost error message in case when oplog was truncated "irregularly" during the initial sync.

      Oplog is a capped collection and it is truncated regularly when the collection size exceeds the configured size. However, truncation can also be caused by the initial sync when a node is added to an existing replica set (see SERVER-121956).

            Assignee:
            Unassigned
            Reporter:
            Romans Kasperovics
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Created:
              Updated: