-
Type:
Task
-
Resolution: Unresolved
-
Priority:
Major - P3
-
None
-
Affects Version/s: None
-
Component/s: None
-
None
-
Query Integration
-
None
-
None
-
None
-
None
-
None
-
None
-
None
SERVER-88167 exposed additional fromMigrate: true fields to change stream events that originate from a migration. These fields are only exposed if the change stream is opened with showMigrationEvents: true.
SERVER-88167 (intentionally) kept the existing limitation of showMigrationEvents only being usable when opening a change stream on a shard mongod. That means even after SERVER-88167 trying to open a change stream on mongos would still fail with error 31123 as before.
To lift this restriction and allow opening change streams with the showMigrationEvents flag also on mongos, this erroring needs to be removed and additional sharded cluster change streams for showMigrationEvents: true need to be added.
- is related to
-
SERVER-88167 Expose information about change event being from a migration event when change streams run with showMigrationEvents:true
-
- Closed
-