• Type: Task
    • Resolution: Unresolved
    • Priority: Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • None
    • Cluster Scalability
    • 3
    • None
    • None
    • None
    • None
    • None
    • None
    • None

      When resharding recipient is running under wt cache pressure. It's operation can get killed by WT and throw an error that is currently not retryable:

      shard-2 reached an unrecoverable error :: caused by :: WiredTigerIdIndex::insert: index: _id; uri: table:index-81229-14547801253578948280 -31800: oldest pinned transaction ID rolled back for eviction

      I believe this is normally handled in other write paths with the write conflict retry loop. We should investigate whether resharding can safely retry this.

            Assignee:
            Unassigned
            Reporter:
            Randolph Tan
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated: