Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-13979

rename (or alias) findAndModify to modifyAndReturn

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Usability
    • Labels:
      None

      Description

      A lot of confusion is caused by the name of `findAndModify` command as "find and modify" is literally what an update does. Since findAndModify actually returns the document that was updated, a less confusing name would be something descriptive like modifyAndReturn or updateAndReturn.

      To be not-backwards breaking it could be an alias for existing command until such time as it could be deprecated.

        Attachments

          Activity

            People

            • Votes:
              11 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: