Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-14741

linenoise does not erase characters at end of line when backspacing over multi-byte characters in Windows

    • Type: Icon: Bug Bug
    • Resolution: Unresolved
    • Priority: Icon: Minor - P4 Minor - P4
    • None
    • Affects Version/s: None
    • Component/s: Shell
    • ALL

      SERVER-6086 fixed the issue with moving the cursor over multi-byte characters but exposed a flaw in the Windows redrawing code as described below:


      Comments in SERVER-6086:

      The cursor navigation works now. When I move the cursor under the chinese characters, the entire character is underlined(as opposed to be half). And press the arrow key once does move one char over.
      Looking at the screenshot(see attachment image.png), you can notice there is some cosmetic issue. I tried to hit backspace 3 times when the cursor is at the last double quote mark. 3 chinese characters were deleted as expected, however, there are some extra curly brackets being shown in the end. If you hit enter, the statement would just work fine so it's just cosmetic.

            backlog-server-platform DO NOT USE - Backlog - Platform Team
            benety.goh@mongodb.com Benety Goh
            0 Vote for this issue
            1 Start watching this issue