Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-14811

Attempting scons install on centos installation results in error abour missing candle.exe

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
      None
    • Operating System:
      ALL
    • Steps To Reproduce:

      download source
      extract source
      cd to source dir
      sudo scons all
      sudo scons install

      Show
      download source extract source cd to source dir sudo scons all sudo scons install

      Description

      Trying to build / install mongo on a Centos vm.

      "\bin\candle.exe" -wx -dMongoDBMajorVersion=2.6 -dMongoDBVersion=2.6.3 -dLicenseSource=distsrc -dEnterpriseBase=src\mongo\db\modules\enterprise\ -dBinarySource=build/linux2/normal\mongo -dMergeModulesBasePath="" -dEdition=Standard -d"ProductId=*" -dUpgradeCode=6A44D061-6FA9-438B-8D25-4AF1BBAC61D7 -dClientSource=build/linux2/normal\client_build -dClientHeaderSource=/usr/local\include\mongo -dConfiguration=Release -dOutDir=build/linux2/normal\msi -dPlatform=x64 -dFlavor=Legacy -dProjectDir=buildscripts\packaging\msi
      -dProjectName=MongoDB -dTargetDir=build/linux2/normal\msi -dTargetExt=.msi -dTargetFileName=mongodb-linux-x86_64-2.6.3.tgz -dSaslSource=c:\sasl\bin -dSnmpSource=c:\snmp\bin -dSslSource=c:\openssl\bin -out build/linux2/normal\msi
      -arch x64 -ext "\bin\WixUIExtension.dll" src/mongo/installer/msi/wxs/BinaryFragment.wxs src/mongo/installer/msi/wxs/FeatureFragment.wxs src/mongo/installer/msi/wxs/LicensingFragment.wxs src/mongo/installer/msi/wxs/Installer_64.wxs
      sh: \bin\candle.exe: command not found
      scons: *** [build/linux2/normal/msi/BinaryFragment.wixobj] Error 127
      scons: building terminated because of errors.

      src downloaded 20140806 from https://fastdl.mongodb.org/src/mongodb-src-r2.6.3.tar.gz

        Activity

        milkie Eric Milkie added a comment -

        There is a small build dependency issue with our SConstruct that causes this problem if your install directory is a parent of the directory where you are attempting to build. Essentially, it causes scons to build all targets it can find in all subdirectories, even ones that are only intended for Windows.
        Since the default install directory on your platform is /usr/local, did you happen to extract the source into a subdirectory of that path?

        sarodude saro marcarian added a comment -

        Yes - /usr/local/src. Will try moving source someplace else.

        sarodude saro marcarian added a comment -

        Build was successful after moving source dir. Thanks! Ticket can be closed.

        But I do have a question... Is scons install expected to setup the daemon / service?

        milkie Eric Milkie added a comment -

        "scons install" is like "make install", it just copies files. The yum package installer gives you a bit more, so that you can start the service with the "service" command.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: