Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-15354

Implementing cluster index for RocksDB

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Storage
    • Labels:

      Description

      In most cases, querys are focused on the same shardkey, so implementing a cluster index on shardkey will be very friendly for query.

      RocksDB can sort data by the key, so there can be a way to do this.

      Thanks

        Issue Links

          Activity

          chengas123 Ben McCann added a comment -

          Hi, I'm curious to learn more about this as I'm interested in working on performance improvements to RocksDB. I just got a huge speedup for RocksDB by fixing https://jira.mongodb.org/browse/SERVER-15793 on my machine. What do you mean by a "cluster index on shardkey"?

          pasette Dan Pasette added a comment -

          This ticket refers to creating a clustered index, that is, storing the data in index-sorted order. See: http://en.wikipedia.org/wiki/Database_index#Clustered. The advantage of having a clustered index on shard key is that logical "chunks" of data which are migrated from shard to shard are also physically stored contiguously on disk.

          chengas123 Ben McCann added a comment -

          Thanks for confirming, Dan. I wasn't entirely sure whether this was referring to a clustered index or not. I guess this is a pretty decent sized feature, but it would be very cool to have.

          ramon.fernandez Ramon Fernandez added a comment -

          This ticket is a duplicate of SERVER-3294, so I'm closing it. Feel free to vote for and watch SERVER-3294 for updates.

          Regards,
          Ramón.


            People

            • Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: