Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-15555

Building should not depend on pymongo

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 2.7.7
    • Fix Version/s: 2.7.8
    • Component/s: Build
    • Labels:
      None
    • Environment:
      OS X 10.8, 10.9, 10.10
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      OS X
    • Steps To Reproduce:
      Hide

      Attempt to build.
      Fails?

      Show
      Attempt to build. Fails?

      Description

      2.7.7 & the Github HEAD build seem to be failing to build entirely. Trying to bump versions from 2.7.6 to 2.7.7 but it nearly insta-fails with the message outputted below.

      This is the error:

      ==> /usr/local/opt/scons/bin/scons all --prefix=/usr/local/Cellar/mongodb/2.7.7_1 -j4 --cc=/usr/bin/clang --cxx=/usr/bin/clang++ --osx-version-min=10.10 --64
      scons: Reading SConscript files ...
      Mkdir("build/scons")
      scons version: 2.3.4
      python version: 2 7 8 'final' 0
      EnvironmentError: No module named pymongo:
      File "/private/tmp/mongodb-i75K6y/mongodb-src-r2.7.7/SConstruct", line 515:
      env = Environment(**envDict)
      File "/usr/local/Cellar/scons/2.3.4/libexec/scons-local/SCons/Environment.py", line 1003:
      apply_tools(self, tools, toolpath)
      File "/usr/local/Cellar/scons/2.3.4/libexec/scons-local/SCons/Environment.py", line 107:
      env.Tool(tool)
      File "/usr/local/Cellar/scons/2.3.4/libexec/scons-local/SCons/Environment.py", line 1810:
      tool = SCons.Tool.Tool(tool, toolpath, **kw)
      File "/usr/local/Cellar/scons/2.3.4/libexec/scons-local/SCons/Tool/_init_.py", line 97:
      module = self._tool_module()
      File "/usr/local/Cellar/scons/2.3.4/libexec/scons-local/SCons/Tool/_init_.py", line 118:
      raise SCons.Errors.EnvironmentError(e)
      /usr/local/Library/Homebrew/debrew.rb:10:in `raise'
      BuildError: Failed executing: /usr/local/opt/scons/bin/scons all --prefix=/usr/local/Cellar/mongodb/2.7.7_1 -j4 --cc=/usr/bin/clang --cxx=/usr/bin/clang++ --osx-version-min=10.10 --64

      I am using Homebrew & we are using the build arguments:

      --prefix=#

      Unknown macro: {prefix}

      -j#

      Unknown macro: {ENV.make_jobs}

      --cc=#

      Unknown macro: {ENV.cc}

      --cxx=#

      Unknown macro: {ENV.cxx}

      --osx-version-min=#

      Unknown macro: {MacOS.version}

        Attachments

        1. 01.scons
          1 kB
        2. mongodb.rb
          4 kB

          Issue Links

            Activity

              People

              Assignee:
              ernie.hershey Ernie Hershey
              Reporter:
              DomT4 Dominyk Tiller [X]
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: