Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-16664

Segmentation fault on insert operation with Tiger engine / zlib compressor

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 2.8.0-rc4
    • Fix Version/s: 3.0.0-rc6
    • Component/s: Storage
    • Labels:
      None
    • Environment:
      CentOS release 6.4 (Final), running on on VMWare.
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      Linux
    • Steps To Reproduce:

      1. Start Mongo with extra options;
      2. Insert documents into collection (~200 100kb XMLs through perl driver).

      Show
      1. Start Mongo with extra options; 2. Insert documents into collection (~200 100kb XMLs through perl driver).

      Description

      Segmentation fault occures on insert operation with Tiger engine.

      Server startup options:

      /usr/bin/mongod --quiet -f /etc/mongodb.conf --storageEngine wiredtiger --wiredTigerJournalCompressor snappy --wiredTigerCollectionBlockCompressor snappy run

      Used version:

      mongodb-linux-x86_64-6105f06402fe1e7578d41f3e4e583a1476ef2455-2014-12-23

      Happened twice - with snappy and zlib compressors.
      Couldn't reproduce with higher log levels.

      1. lol.pl
        4 kB
        Konstantin Koshelyaev
      2. lol-frequent-connect.pl
        4 kB
        Konstantin Koshelyaev
      3. mongo-crash.log
        62 kB
        Konstantin Koshelyaev
      4. mongodb.log-crash
        4 kB
        Konstantin Koshelyaev

        Activity

        tirramissu Konstantin Koshelyaev added a comment -

        Sure. How can I attach it privately? I've got only 'Users' and 'All users' group available in attachment dialog.

        ramon.fernandez Ramon Fernandez added a comment -

        All,

        I'm able to easily reproduce the problem using 2.8.0-rc3, but not with 2.8.0-rc4. Konstantin Koshelyaev, can you please confirm whether you see the segfault on your end when using 2.8.0-rc4?

        ramon.fernandez Ramon Fernandez added a comment -

        Nevermind – the segfault does trigger in 2.8.0-rc4 as well, it jut took a tad longer.

        tirramissu Konstantin Koshelyaev added a comment -

        You still need an XML?

        ramon.fernandez Ramon Fernandez added a comment -

        Thanks Konstantin Koshelyaev, we no longer need the XML data. We're able to reproduce with a XML file set we already have access to and we're investigating.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            11 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: