Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Gone away
    • Affects Version/s: 3.0.0-rc7
    • Fix Version/s: None
    • Component/s: JavaScript
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Steps To Reproduce:

      run jstest/sharding/features1.js

      100% reproducible on local machine (but not on debug build), based on commit ac9ee2fb80f2afc2737a0d9f346cff8117a82af2, built on g++ 4.9.2.

      Show
      run jstest/sharding/features1.js 100% reproducible on local machine (but not on debug build), based on commit ac9ee2fb80f2afc2737a0d9f346cff8117a82af2, built on g++ 4.9.2.

      Description

       m30001|  mongod(_ZN5mongo15printStackTraceERSo+0x2B) [0x111707b]
       m30001|  mongod(+0xD168A2) [0x11168a2]
       m30001|  mongod(+0xD16C46) [0x1116c46]
       m30001|  libpthread.so.0(+0xFBD0) [0x7f668addbbd0]
       m30001|  mongod(+0xE164D1) [0x12164d1]
       m30001|  mongod(_ZN2v82V837AdjustAmountOfExternalAllocatedMemoryEl+0x88) [0x122c438]
       m30001|  mongod(_ZN5boost6detail17sp_counted_impl_pIN5mongo10BSONHolderEE7disposeEv+0x63) [0x108ad43]
       m30001|  mongod(_ZN5mongo10ObjTrackerINS_10BSONHolderEED2Ev+0x8D) [0x108b1dd]
       m30001|  mongod(_ZN5mongo7V8ScopeD2Ev+0x227) [0x1080247]
       m30001|  mongod(_ZN5mongo7V8ScopeD0Ev+0x9) [0x10802a9]
       m30001|  mongod(+0x68B64C) [0xa8b64c]
       m30001|  mongod(+0x68C1A7) [0xa8c1a7]
       m30001|  mongod(_ZN5mongo12_execCommandEPNS_16OperationContextEPNS_7CommandERKSsRNS_7BSONObjEiRSsRNS_14BSONObjBuilderEb+0x2C) [0xa734bc]
       m30001|  mongod(_ZN5mongo7Command11execCommandEPNS_16OperationContextEPS0_iPKcRNS_7BSONObjERNS_14BSONObjBuilderEb+0xEAE) [0xa745ee]
       m30001|  mongod(_ZN5mongo12_runCommandsEPNS_16OperationContextEPKcRNS_7BSONObjERNS_11_BufBuilderINS_16TrivialAllocatorEEERNS_14BSONObjBuilderEbi+0x62C) [0xa7544c]
       m30001|  mongod(_ZN5mongo8runQueryEPNS_16OperationContextERNS_7MessageERNS_12QueryMessageERKNS_15NamespaceStringERNS_5CurOpES3_b+0x202A) [0xcb56ea]
       m30001|  mongod(_ZN5mongo16assembleResponseEPNS_16OperationContextERNS_7MessageERNS_10DbResponseERKNS_11HostAndPortEb+0xA15) [0xb908c5]
       m30001|  mongod(_ZN5mongo16MyMessageHandler7processERNS_7MessageEPNS_21AbstractMessagingPortEPNS_9LastErrorE+0xDD) [0x8098ed]
       m30001|  mongod(_ZN5mongo17PortMessageServer17handleIncomingMsgEPv+0x2E3) [0x10d4063]
       m30001|  libpthread.so.0(+0x7F8E) [0x7f668add3f8e]
       m30001|  libc.so.6(clone+0x6D) [0x7f6689ecba0d]
       m30001| -----  END BACKTRACE  -----

      Stacktrace from gdb:

      #0  v8::V8::AdjustAmountOfExternalAllocatedMemory (change_in_bytes=-46) at src/third_party/v8/src/api.cc:5280
      #1  0x000000000108ac7c in ~BSONHolder (this=0x3a236d0, __in_chrg=<optimized out>) at src/mongo/scripting/engine_v8.h:563
      #2  checked_delete<mongo::BSONHolder> (x=0x3a236d0) at src/third_party/boost/boost/checked_delete.hpp:39
      #3  boost::detail::sp_counted_impl_p<mongo::BSONHolder>::dispose (this=<optimized out>) at src/third_party/boost/boost/smart_ptr/detail/sp_counted_impl.hpp:78
      #4  0x0000000001080141 in release (this=0x744efe0) at src/third_party/boost/boost/smart_ptr/detail/sp_counted_base_gcc_x86.hpp:145
      #5  ~shared_count (this=0x744efc8, __in_chrg=<optimized out>) at src/third_party/boost/boost/smart_ptr/detail/shared_count.hpp:305
      #6  ~shared_ptr (this=0x744efc0, __in_chrg=<optimized out>) at src/third_party/boost/boost/smart_ptr/shared_ptr.hpp:164
      #7  ~TrackedPtr (this=0x744efc0, __in_chrg=<optimized out>) at src/mongo/scripting/engine_v8.h:105
      #8  ~ObjTracker (this=0x371e080, __in_chrg=<optimized out>) at src/mongo/scripting/engine_v8.h:95
      #9  mongo::V8Scope::~V8Scope (this=0x371e000, __in_chrg=<optimized out>) at src/mongo/scripting/engine_v8.cpp:574
      #10 0x00000000010801d9 in mongo::V8Scope::~V8Scope (this=0x371e000, __in_chrg=<optimized out>) at src/mongo/scripting/engine_v8.cpp:576
      #11 0x0000000000a8b59c in checked_delete<mongo::Scope> (x=0x371e000) at src/third_party/boost/boost/checked_delete.hpp:39
      #12 ~scoped_ptr (this=<synthetic pointer>, __in_chrg=<optimized out>) at src/third_party/boost/boost/smart_ptr/scoped_ptr.hpp:80
      #13 mongo::(anonymous namespace)::dbEval (txn=txn@entry=0x7fc843f76790, dbName=..., cmd=..., result=..., errmsg=...) at src/mongo/db/dbeval.cpp:143
      #14 0x0000000000a8c0f7 in mongo::(anonymous namespace)::CmdEval::run (this=<optimized out>, txn=0x7fc843f76790, dbname=..., cmdObj=..., options=<optimized out>, errmsg=..., result=..., fromRepl=false) at src/mongo/db/dbeval.cpp:184
      #15 0x0000000000a7340c in mongo::_execCommand (txn=txn@entry=0x7fc843f76790, c=c@entry=0x1c43080 <mongo::(anonymous namespace)::cmdeval>, dbname=..., cmdObj=..., queryOptions=queryOptions@entry=0, errmsg=..., result=..., 
          fromRepl=false) at src/mongo/db/dbcommands.cpp:1273
      #16 0x0000000000a7453e in mongo::Command::execCommand (txn=txn@entry=0x7fc843f76790, c=c@entry=0x1c43080 <mongo::(anonymous namespace)::cmdeval>, queryOptions=queryOptions@entry=0, cmdns=cmdns@entry=0x3a18c14 "test.$cmd", cmdObj=..., 
          result=..., fromRepl=false) at src/mongo/db/dbcommands.cpp:1489
      #17 0x0000000000a7539c in mongo::_runCommands (txn=0x7fc843f76790, txn@entry=0x40, ns=0x3a18c14 "test.$cmd", _cmdobj=..., b=..., anObjBuilder=..., fromRepl=fromRepl@entry=false, queryOptions=0) at src/mongo/db/dbcommands.cpp:1561
      #18 0x0000000000cb563a in runCommands (fromRepl=false, queryOptions=<optimized out>, anObjBuilder=..., b=..., curop=..., jsobj=..., ns=<optimized out>, txn=0x40) at src/mongo/db/query/find.cpp:137
      #19 mongo::runQuery (txn=0x40, txn@entry=0x7fc843f76790, m=..., q=..., nss=..., curop=..., result=..., fromDBDirectClient=false) at src/mongo/db/query/find.cpp:606
      #20 0x0000000000b90815 in receivedQuery (fromDBDirectClient=false, m=..., dbresponse=..., c=..., txn=0x7fc843f76790) at src/mongo/db/instance.cpp:220
      #21 mongo::assembleResponse (txn=txn@entry=0x7fc843f76790, m=..., dbresponse=..., remote=..., fromDBDirectClient=fromDBDirectClient@entry=false) at src/mongo/db/instance.cpp:403
      #22 0x000000000080983d in mongo::MyMessageHandler::process (this=<optimized out>, m=..., port=0x3a224b0, le=0x3a23540) at src/mongo/db/db.cpp:206
      #23 0x00000000010d3f23 in mongo::PortMessageServer::handleIncomingMsg (arg=0x3a224b0) at src/mongo/util/net/message_server_port.cpp:229
      #24 0x00007fc854856f8e in start_thread (arg=0x7fc843f77700) at pthread_create.c:311
      #25 0x00007fc85394ea0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

      It looks like i::Isolate::Current(); was returning NULL.

        Issue Links

          Activity

          schwerin Andy Schwerin added a comment -

          GCC 4.9.X generates bad code for our old version of V8, or more likely, causes the V8 jit to generate bad code.

          crystal.horn Crystal Horn added a comment -

          Gone Away with Spidermonkey implementation


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: