Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-17149

Can't mirror your debian repository

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Packaging
    • Labels:
    • Environment:
      debian squeeze
      debian wheezy
      aptly - debian repository management tool
    • Operating System:
      Linux

      Description

      We use aptly for mirroring your repository, but since October it doesn't work.
      Update script ends with message:
      ERROR: unable to update: component 10gen not available in repo [mongo]: http://downloads-distro.mongodb.org/repo/debian-sysvinit/ dist

      We think, that the cause is wrong directive settings in this file: http://downloads-distro.mongodb.org/repo/debian-sysvinit/dists/dist/Release
      There is
      Components: mongodb
      and should be
      Components: 10gen

      Target of your actual settings is URL: http://downloads-distro.mongodb.org/repo/debian-sysvinit/dists/dist/mongodb which doesn't exist.

      There are two solutions

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              michael.paik Michael Paik
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: