Now that records are identified by a RecordId rather than a DiskLoc, could we rename showDiskLoc to showRecordId in the shell? If I understand correctly, non-MMAPv1 storage engines don't use DiskLocs, and reporting "file" and "offset" isn't correct:
> db.foo.find({}, {_id: 0}).showDiskLoc() { "i" : 0, "$diskLoc" : { "file" : 0, "offset" : 1 } } { "i" : 1, "$diskLoc" : { "file" : 0, "offset" : 2 } } { "i" : 2, "$diskLoc" : { "file" : 0, "offset" : 3 } } { "i" : 3, "$diskLoc" : { "file" : 0, "offset" : 4 } } { "i" : 4, "$diskLoc" : { "file" : 0, "offset" : 5 } } { "i" : 5, "$diskLoc" : { "file" : 0, "offset" : 6 } } { "i" : 6, "$diskLoc" : { "file" : 0, "offset" : 7 } } { "i" : 7, "$diskLoc" : { "file" : 0, "offset" : 8 } } { "i" : 8, "$diskLoc" : { "file" : 0, "offset" : 9 } } { "i" : 9, "$diskLoc" : { "file" : 0, "offset" : 10 } } { "i" : 10, "$diskLoc" : { "file" : 0, "offset" : 11 } } { "i" : 11, "$diskLoc" : { "file" : 0, "offset" : 12 } } { "i" : 12, "$diskLoc" : { "file" : 0, "offset" : 13 } } { "i" : 13, "$diskLoc" : { "file" : 0, "offset" : 14 } } { "i" : 14, "$diskLoc" : { "file" : 0, "offset" : 15 } }
http://docs.mongodb.org/manual/reference/operator/meta/showDiskLoc/
- related to
-
DRIVERS-219 Change showDiskLoc to showRecordId
- Closed