Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-18051

OpenSSL internal error when using SCRAM-SHA1 authentication in FIPS mode

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • 3.0.2, 3.1.1
    • 3.0.3, 3.1.2
    • Security
    • None
    • Fully Compatible
    • ALL
    • Security 2 04/24/15
    • 0

    Description

      When running with SCRAM-SHA1 authentication and --sslFIPSMode, openssl asserts with this error message:
      OpenSSL internal error, assertion failed: Low level API call to digest SHA1 forbidden in FIPS mode!
      2015-04-13T23:23:27.498Z F - Got signal: 6 (Abort).

      Attachments

        Activity

          People

            andreas.nilsson Andreas Nilsson
            ernie.hershey@mongodb.com Ernie Hershey
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: