Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-19086

Unable to run mongod.exe on Windows 10 due to missing libraries

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: 3.0.4
    • Fix Version/s: None
    • Component/s: Stability
    • Labels:
      None
    • Operating System:
      ALL
    • Steps To Reproduce:

      Install Windows 10, run any of the executables in the bin folder.

      Show
      Install Windows 10, run any of the executables in the bin folder.

      Description

      ---------------------------
      mongod.exe - System Error
      ---------------------------
      The program can't start because LIBEAY32.dll is missing from your computer. Try reinstalling the program to fix this problem.
      ---------------------------
      OK
      ---------------------------

        Issue Links

          Activity

          bniemyjski Blake Niemyjski added a comment -

          Copying libeay32.dll and ssleay32.dll from here ( http://indy.fulgan.com/SSL/ ) into the bin folder solved the issue.. However, these files should be included in the bin folder / msi so users don't run into this on a fresh windows 10 install..

          bniemyjski Blake Niemyjski added a comment -

          Also can't restore:

          ---------------------------
          mongorestore.exe - Entry Point Not Found
          ---------------------------
          The procedure entry point TLSv1_1_method could not be located in the dynamic link library D:\mongodb\bin\mongorestore.exe.
          ---------------------------
          OK
          ---------------------------

          bniemyjski Blake Niemyjski added a comment -

          mongodb-win32-x86_64-2008plus-ssl-3.0.4.zip

          ramon.fernandez Ramon Fernandez added a comment -

          Blake Niemyjski, the zip files currently do not contain SSL libraries, please use the MSI packages. SERVER-17368 was opened to include these libraries in zip files as well, so I'm going to close this ticket as a duplicate. Feel free to tune in to SERVER-17368 for updates.

          Regards,
          Ramón.

          bniemyjski Blake Niemyjski added a comment -

          @ramon please reopen this... This is more of an issue than just those files missing.. I installed open ssl on windows 10 and it failed to launch. When I copy these assemblies to the folder the restore process still fails. There is definitely an issue with mongo on windows 10.

          ramon.fernandez Ramon Fernandez added a comment -

          Blake Niemyjski, can you please install MongoDB using the MSI package and let us know if the binaries, including mongorestore.exe, work on Windows 10?

          Thanks,
          Ramón.

          bniemyjski Blake Niemyjski added a comment -

          Thanks, that worked.. I'm wondering if it was just caused by different versions of open ssl (I was using the latest and it still wasn't working).

          ramon.fernandez Ramon Fernandez added a comment -

          Thanks Blake Niemyjski, good to hear that you're up and running. We're aware it's confusing to install MongoDB on Windows from a zip file and have binaries fail if the library dependencies are not met, and we intend to address that in SERVER-17368 so I'm going to close this ticket.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: