Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-19755

scons should require c++11 on 3.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.8
    • Component/s: Build
    • Labels:
      None
    • Backwards Compatibility:
      Major Change
    • Operating System:
      ALL
    • Sprint:
      Platform 8 08/28/15, Platform 9 (09/18/15), Platform B (10/30/15)

      Description

      Now that we allow C++11 code in the 3.0 branch, scons should always require C++11 and fail if the compiler doesn't support it.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: