Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-21013

benchRun() query option "filter" should be renamed "projection"

    XMLWordPrintable

    Details

      Description

      The option to specify a projection to a find query in benchRun is named "filter". This option is misnamed; it should be named "projection".

      This ticket also requires changes to the mongo-perf repository (the "simple query" suite includes query test cases that depend on the naming of this option).

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated: