Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-21971

Not possible to elect a primary if non-voting member is ahead (PV0)

    XMLWordPrintable

    Details

    • Backwards Compatibility:
      Minor Change
    • Operating System:
      ALL
    • Backport Completed:

      Description

      Due to sync source selection and vetoing, it is possible for a non-votable to block elections due to holding newer data no other voting member will be able to replicate. Since vetoing is only in protocol version 0 (PV0) this only affects replica sets which haven't upgraded.

      The obvious workaround to this issue is to update to protocol version 1.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              scotthernandez Scott Hernandez
              Reporter:
              scotthernandez Scott Hernandez
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: