Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-22274

WiredTiger cache size is only configurable in whole gigabytes.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0.8
    • Fix Version/s: None
    • Component/s: WiredTiger
    • Labels:
      None
    • Operating System:
      ALL

      Description

      Hello, on our development servers we currently run our application server alongside a standalone mongod instance. Ever since WiredTiger was introduced we have the occasional OOM killer issue where app server RAM + WT cache + file system buffers are way higher than these smaller instances have.

      I was looking into overriding the WT cache size into something smaller and found this option:
      https://docs.mongodb.org/manual/reference/configuration-options/#storage.wiredTiger.engineConfig.cacheSizeGB

      The problem is that this only allows this value to be specified in whole gigabytes while total RAM of these instances is only 1 or 2 Gb. Specifying this value as a fraction results in parse errors as this field is parsed as an integer. I also tried other key names such as 'cacheSizeMB' or 'cacheSize' without any luck. I also tried using a letter as in indicator ('200M') but that leads to another parsing error.

      I found a workaround in this post but that does not seem to work (anymore?):
      https://groups.google.com/forum/#!topic/mongodb-user/GLrp-H31YWg

      Are there plans to specify this value in a more specific way. Also, is there a current workaround for this?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kelsey.schubert Kelsey T Schubert
              Reporter:
              jeroenv Jeroen Vijfhuizen
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: