Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-24240

Ubuntu 16.04 on the v3.2 branch needs to compile with the v2 toolchain

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.7
    • Component/s: Build
    • Labels:

      Description

      For Ubuntu 16.04, we need to use the v2 toolchain, since the v1 toolchain doesn't build or run there.

      The master branch builds cleanly with the v2 toolchain, but the v3.2 branch does not. If we want to do 3.2.x stable releases for 16.04 (and we do), then we will need to make the v3.2 branch compatible with the v2 toolchain.

      This will also make it easier for developers, since they can then use the same toolchain to build both branches.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: