Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-25496

the validate hook will not work with older versions of mongod

    XMLWordPrintable

    Details

    • Backwards Compatibility:
      Fully Compatible

      Description

      as part of SERVER-24506, the validate hook was modified to support views.

      A side effect is that it will silently not run with older versions of mongo.

      We should determine if we want to do something about it. One solution is to check the mongod version and use different listCollections logic depending on the version.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              backlog-server-stm Backlog - Server Tooling and Methods (STM)
              Reporter:
              robert.guo Robert Guo
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated: