ExportXMLWordPrintableJSON

    • Type: Bug
    • Resolution: Done
    • Priority: Major - P3
    • 3.4.0-rc3
    • Affects Version/s: None
    • Component/s: Sharding
    • None
    • Fully Compatible
    • ALL
    • Sharding 2016-10-10, Sharding 2016-10-31, Sharding 2016-11-21
    • None
    • None
    • None
    • None
    • None
    • None
    • None

      ShardRemote::updateReplSetMonitor marks a host as not master on InterruptedDueToReplStateChange errors. However, a mongos can send a command to the config, which then sends to a shard, and the shard returns the error, but the mongos marks the config server as not master.

      This is generally true of all errors that are interpreted as the first contacted server's fault, not any subsequent servers that are called down the line.

      This is an issue for existing config commands that forward commands to the shards and return that result (like the balancer!)

            Assignee:
            Dianna Hohensee (Inactive)
            Reporter:
            Dianna Hohensee (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Created:
              Updated:
              Resolved: