Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-26564

Yum errors out when trying to install mongo-org on RHEL 7.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.4.0-rc1
    • Component/s: Packaging
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Sprint:
      Evergreen 2016-10-31
    • Linked BF Score:
      0

      Description

      Here's the output from the command line:
      Dependencies Resolved

      ===================================================================================================================================================================================
      Package Arch Version Repository Size
      ===================================================================================================================================================================================
      Installing:
      mongodb-org x86_64 3.2.10-1.el7 mongodb 5.8 k
      Installing for dependencies:
      mongodb-org-mongos x86_64 3.2.10-1.el7 mongodb 5.6 M
      mongodb-org-server x86_64 3.2.10-1.el7 mongodb 5.5 M
      mongodb-org-shell x86_64 3.2.10-1.el7 mongodb 6.7 M
      mongodb-org-tools x86_64 3.2.10-1.el7 mongodb 41 M

      Transaction Summary
      ===================================================================================================================================================================================
      Install 1 Package (+4 Dependent packages)

      Total size: 59 M
      Total download size: 5.5 M
      Installed size: 201 M
      Is this ok [y/d/N]: y
      Downloading packages:
      mongodb-org-server-3.2.10-1.el FAILED [=====================================- ] 0.0 B/s | 3.2 MB -::- ETA
      https://repo.mongodb.org/yum/redhat/7Server/mongodb-org/3.2/x86_64/RPMS/mongodb-org-server-3.2.10-1.el7.x86_64.rpm: [Errno 14] curl#63 - "Callback aborted" | 3.2 MB -::- ETA
      Trying other mirror.

      Error downloading packages:
      mongodb-org-server-3.2.10-1.el7.x86_64: [Errno 256] No more mirrors to try.

      I'm not having issues on other OSes (CentOS 7, CentOS 6, RHEL 6). Just RHEL7.

      I can download the RPM with my browser just fine, so I think the issue is with a GPG key

      The URL for the mongo repo is:
      https://repo.mongodb.org/yum/redhat/$releasever/mongodb-org/3.2/x86_64/

      On my redhat server, the $releasever variable resolves to "7Server".

      Browsing to "https://repo.mongodb.org/yum/redhat/", and can see that "7" is an available option. I changed the $releasever variable to that in my mongo repo file, and then run the yum install. It asks me to accept a key, and then the install works.

      Here's the request to accept the key:
      Retrieving key from https://www.mongodb.org/static/pgp/server-3.2.asc
      Importing GPG key 0xEA312927:
      Userid : "MongoDB 3.2 Release Signing Key <packaging@mongodb.com>"
      Fingerprint: 42f3 e95a 2c4f 0827 9c49 60ad d68f a50f ea31 2927
      From : https://www.mongodb.org/static/pgp/server-3.2.asc
      Is this ok [y/N]: y

      Because I was suspicious about the key being the issue, I tried removing the mongodb-org, switching my repo back to using $relesasever, and then installing mongodb-org again. This time it worked.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: