Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-27368

Balancer not working on 3.4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Done
    • Affects Version/s: 3.4.0
    • Fix Version/s: None
    • Component/s: Sharding
    • Labels:
      None
    • Operating System:
      ALL
    • Steps To Reproduce:
      Hide

      Had 4 3.2.10 instances on a Windows Server 2012 development server(1 mongos, 2 shard instances, 1 config) all mongods setup as replicas even though they were standalone instances in the development environment
      Tried to deploy 3.4 using guidelines from website and after finally getting it back up found log errors for unable to connect to config server causing balancer to not work and database became unstable

      Show
      Had 4 3.2.10 instances on a Windows Server 2012 development server(1 mongos, 2 shard instances, 1 config) all mongods setup as replicas even though they were standalone instances in the development environment Tried to deploy 3.4 using guidelines from website and after finally getting it back up found log errors for unable to connect to config server causing balancer to not work and database became unstable

      Description

      Hello, I recently tried to deploy MongoDB 3.4 to my sharded cluster running 3.2.10. After a lot of trouble including having to re deploy the setup I was able to get all components on, but then discovered that the balancer wasn't working and I was getting multiple errors of the config server timing out and read/write concerns throwing warnings and even the other components saying it was down when it wasn't. Either way I still couldn't get it to balance even adding another shard would not start moving chunks over so I reverted back to 3.2.10 and it works normal. I have attached log files for each component during the time when 3.4 was deployed(look around 12:30 time stamps onward on the log files to see the relevant info when the 3.4 instances were started up) and can provide other things such as config files diagnostic data etc if needed to help but I believe it is a bug because when reverted back to 3.2.10 it was balancing and working as expected.

        Attachments

        1. mongodConfig.log
          57.29 MB
        2. mongodRouter.log
          10.72 MB
        3. mongodShard1.log
          17.80 MB
        4. mongodShard2.log
          2.63 MB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: