Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-27462

Remove Python 2.6 compatibility code from scripts in buildscripts/ directory

    XMLWordPrintableJSON

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.5.5
    • None
    • Fully Compatible
    • Platforms 2017-03-06, Platforms 2017-03-27

    Description

      The following files have Python 2.6 compatibility code which we can remove once we have Python 2.7 in the toolchain:

      • buildscripts/buildlogger.py
      • buildscripts/burn_in_tests.py
      • buildscripts/clang_format.py
      • buildscripts/eslint.py
      • buildscripts/hang_analyzer.py

      We should consider fixing this on older branches, when reasonable.

      Attachments

        Issue Links

          Activity

            People

              mark.benvenuto@mongodb.com Mark Benvenuto
              andrew.morrow@mongodb.com Andrew Morrow (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: