Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-27944

mongodb 3.4.1 OOM when add new node to replica set

    • Type: Icon: Bug Bug
    • Resolution: Duplicate
    • Priority: Icon: Critical - P2 Critical - P2
    • None
    • Affects Version/s: 3.4.1
    • Component/s: Admin
    • Labels:
    • ALL

      OOM when add new node to replica set

      We meet a OOM problem when we add a new node(with 16GB memory) to replica set , there are about 200GB data on primary node , it takes 1 hours before OOM . We have tried some times, but same result.

      "top" command has been run on our linux system there are almost no buffer,Cache,Free memory before OOM.

      We notice there are much "building index using bulk method; build may temporarily use up to 500 megabytes of RAM" in log. We found a parameter named "secondaryIndexPrefetch" to release resource for building index , but it doesn't work in WT.

        1. disk-mem.png
          140 kB
        2. metrics.2017-01-22T07-45-36Z-00000
          797 kB
        3. metrics.2017-02-14T02-34-24Z-00000
          2.22 MB
        4. mongod_log.gz
          326 kB
        5. mongod.zip
          227 kB
        6. screenshot-1.png
          12 kB
        7. Screen Shot 2017-02-14 at 11.23.28 AM.png
          Screen Shot 2017-02-14 at 11.23.28 AM.png
          144 kB

            mark.agarunov Mark Agarunov
            zhangyu.liu zhangyu.liu
            0 Vote for this issue
            11 Start watching this issue