XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.5.9, 3.4.24
    • Component/s: None
    • Labels:
      None

      Description

      We must upgrade ASIO to the latest unstable release off of https://github.com/chriskohlhoff/asio
      Our previously vendored copy of ASIO does not have support for OpenSSL 1.1.0, which broke API compatibility. ArchLinux has recently upgraded OpenSSL past this threshold. We must upgrade our vendored ASIO to build on this platform, and others which provide this API.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: