As part of the review for
SERVER-28611 we realized we now have some duplicate logic in time_support.h and date_time_support.h. We should re-jigger the libraries and make time_support.h use the new helpers that call into timelib.
The following new format specifiers will also be available after this gets merged:
The abbreviated English name of the day of the week.
The abbreviated English name of the month.
The day of the month as a decimal number, but unlike ``%d``, pre-padded with space instead of a ``0``.