Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-30199

'SConfBase' object has no attribute 'CheckBoostMinVersion'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 3.4.6
    • Fix Version/s: 3.4.7, 3.5.11
    • Component/s: Build
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Backport Requested:
      v3.4
    • Steps To Reproduce:
      Hide

      scons --use-system-boost

      Show
      scons --use-system-boost
    • Sprint:
      Platforms 2017-07-31

      Description

      Latest version (3.4.6) is failing with 'SConfBase' object has no attribute 'CheckBoostMinVersion' when using system boost (check for boost version if performed). With 3.4.3 it was working well for me.

      This error was introduced by this commit https://github.com/mongodb/mongo/commit/5afc2767e74ad25113b2c36be7b18484f156f525

      Patch to fix it is attached.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: