We currently have the audit methods in up to three places (depending on build) with their prototypes existing twice (in audit.cpp and audit.h)
Make audit.cpp a stub-only file (for non-enterprise builds) and define free functions out-of-namespace so that we catch mismatches more quickly. For example: The following two methods existed in audit.cpp only with no header declaration in audit.h nor an implementation in enterprise. We can now catch that properly.
parseAndRemoveImpersonatedUsersField()
parseAndRemoveImpersonatedRolesField()