The state of a task between being scheduled and being executed is variously referred to as "scheduled", "queued", and "pending"; it would be helpful for understanding to use a single term. (This ticket is about the user-visible metric names, but it might also be helpful to use consistent naming in the code).
Specifically, the following metrics relate to executing tasks:
Whereas the comparable metrics relating to the queued tasks are named as follows
To make these consistent and easier to understand propose the following changes:
- totalScheduled -> totalQueued
- queueDepth -> tasksQueued