Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-31349

Rename 'disallowCollectionCreation' generic argument to 'allowImplicitCollectionCreation'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 3.5.13
    • Fix Version/s: 3.6.0-rc0
    • Component/s: Sharding
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Sprint:
      Sharding 2017-10-23

      Description

      The disallowCollectionCreation command argument really means 'disallow implicit collection creation'. And since negative in the name of an argument generally is a source of confusion, we should rename it to 'allowImplicitCollectionCreation', which better conveys its meaning.

        Attachments

          Activity

            People

            Assignee:
            kaloian.manassiev Kaloian Manassiev
            Reporter:
            kaloian.manassiev Kaloian Manassiev
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: