Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-31633

If the featureCompatibilityVersion is 3.6, upgrading, or downgrading, respond to isMaster with minWireVersion=maxWireVersion

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.6.0-rc2
    • Component/s: Replication
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Sprint:
      Query 2017-11-13

      Description

      A 3.6 mongod currently only restricts its supported incoming wire version for internal clients when the featureCompatibilityVersion is 3.6. It must also do this when it is in an upgrading or downgrading featureCompatibilityVersion.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: