Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-32002

serverStatus network.compression.*.{compressed,decompressed}.{bytesIn,bytesOut} names are misleading

    XMLWordPrintable

    Details

    • Backwards Compatibility:
      Minor Change
    • Backport Requested:
      v3.6

      Description

      The "compressed" and "decompressed" parts of the names are misleading as the bytes referred to are not necessarily, as the names imply, compressed or decompressed bytes, i.e.:

      network.compression.snappy.compressed.bytesIn     *** these bytes are not in fact compressed ***
      network.compression.snappy.compressed.bytesOut
      network.compression.snappy.decompressed.bytesIn   *** these bytes are not in fact decompressed ***
      network.compression.snappy.decompressed.bytesOut
      

      This is because these are actually bytes input to and output from the compressor or decompressor, not compressed or decompressed bytes, so it would make sense for the names of the sections to be "compressor" and "decompressor", i.e. change the above names to

      network.compression.snappy.compressor.bytesIn
      network.compression.snappy.compressor.bytesOut
      network.compression.snappy.decompressor.bytesIn
      network.compression.snappy.decompressor.bytesOut
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              bruce.lucas Bruce Lucas
              Reporter:
              bruce.lucas Bruce Lucas
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: