Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-32097

Updating the FCV document directly between 3.4/3.6 can crash secondaries.

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Won't Fix
    • 3.6.0-rc6
    • None
    • Upgrade/Downgrade
    • None
    • ALL
    • Hide

      Attached FSM test.

      Show
      Attached FSM test.
    • 0

    Description

      In particular, secondaries, that believe to be in 3.6, or upgrading to 3.6, can receive oplog documents to create collections that don't contain a UUID. Attached is a reproducing FSM test.

      Attachments

        Issue Links

          Activity

            People

              backlog-server-execution Backlog - Storage Execution Team
              daniel.gottlieb@mongodb.com Daniel Gottlieb
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: