Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-32637

Ensure that upgrading to 3.6 when on pv0 doesn't break if you don't explicitly turn off readConcernMajority

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.6.3
    • Replication, Storage
    • None
    • Minor Change
    • ALL
    • v3.6
    • Storage 2018-01-15, Storage 2018-01-29

    Description

      In 3.6, readConcernMajority support is enabled by default, but having readConcernMajority support enabled while running in replication protocolVersion 0 causes problems. We should ensure that the upgrade to 3.6 works as expected even if using pv0.

      Attachments

        Issue Links

          Activity

            People

              milkie@mongodb.com Eric Milkie
              spencer@mongodb.com Spencer Brody (Inactive)
              Votes:
              1 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: