Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-32992

Report an error when using MongoDB 4.0 binaries with a instance containing V2Unique format index.

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Works as Designed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Storage
    • Sprint:
      Storage Non-NYC 2018-04-09, Storage Non-NYC 2018-07-16, Storage Engines 2018-07-30, Storage Engines 2018-08-13

      Description

      Starting MongoDB 4.0 binaries with an instance containing V2Unique format index should be reported as an error. Report a warning message on startup and an error message the first time a V2Unique index is used, to allow users to remove these using a MongoDB 4.0 binary.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              milkie Eric Milkie
              Reporter:
              neha.khatri Neha Khatri
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: