Two requests. I apologize if these should be separate tickets:
- Please log exactly what database and collection is being queried against for the canary checks. Also include the exact query and the criteria being used to verify the document is in the correct state (I think canary documents are insert only so the verification is an existence check).
- Please rename the powercycle replset name to `powercycle`. It is currently misspelled as `powercyle`. Bringing up a node as a replica set member that can be queried requires an exact string match on the `--replSet` name. It's easy to read the replset name as `powercycle` to only later learn it's misspelled.