Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-34630

Change WiredTiger compatibility version setting in 3.6 release

    XMLWordPrintable

    Details

    • Backwards Compatibility:
      Fully Compatible
    • Sprint:
      Storage Non-NYC 2018-05-07, Storage NYC 2018-05-21
    • Case:

      Description

      We are introducing a log format version change in the 4.0 release, as part of recoverable rollback work. The change is being made in WT-4029.

      We should update MongoDB to pass compatibility=(release=3.0) when it calls wiredtiger_open, so that users who open a database that has been used by MongoDB 4.0 and has not had a clean shutdown get a useful error message.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              alexander.gorrod Alexander Gorrod
              Reporter:
              alexander.gorrod Alexander Gorrod
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: