Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-35277

debian 9 support

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Works as Designed
    • Affects Version/s: 3.6.5
    • Fix Version/s: None
    • Component/s: Packaging
    • Labels:
      None
    • Operating System:
      ALL

      Description

      Hey!

      i am trying to install mongodb 3.6 from http://repo.mongodb.org/apt/debian/ to my clean debian9 vm.

      i got this error

      # apt install  mongodb-org mongodb-org-server  mongodb-org-shell mongodb-org-tools 
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:The following packages have unmet dependencies:
       mongodb-org : Depends: mongodb-org-mongos but it is not going to be installed
       mongodb-org-server : Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
       mongodb-org-shell : Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
       mongodb-org-tools : Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
      E: Unable to correct problems, you have held broken packages.
       
       

       

      that is why

      # apt-cache show mongodb-org-server
      Package: mongodb-org-server
      Source: mongodb-org
      Version: 3.6.5
      Architecture: amd64
      Maintainer: Ernie Hershey <ernie.hershey@mongodb.com>
      Installed-Size: 57883
      Depends: libc6 (>= 2.18), libgcc1 (>= 1:4.1.1), libssl1.0.0 (>= 1.0.1), adduser, tzdata
       

      but there are no package with name libssl1.0.0 and version >= 1.0.1

      debian 9 has only

      # apt-cache search libssl
      cl-plus-ssl - Common Lisp interface to OpenSSL
      dcmtk - OFFIS DICOM toolkit command line utilities
      libdcmtk-dev - OFFIS DICOM toolkit development libraries and headers
      libdcmtk8 - OFFIS DICOM toolkit runtime libraries
      libssl-ocaml - OCaml bindings for OpenSSL (runtime)
      libssl-ocaml-dev - OCaml bindings for OpenSSL
      libssl-dev - Secure Sockets Layer toolkit - development files
      libssl-doc - Secure Sockets Layer toolkit - development documentation
      libssl1.1 - Secure Sockets Layer toolkit - shared libraries
      libssl1.0-dev - Secure Sockets Layer toolkit - development files
      libssl1.0.2 - Secure Sockets Layer toolkit - shared libraries
      perl-openssl-defaults - version compatibility baseline for Perl OpenSSL packages
      r-cran-openssl - GNU R toolkit for encryption, signatures and certificates based on OpenSSL
       

      "libssl1.0.2" and no "libssl1.0.0"

      please fix packet metadata.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: