The naming for replication helper threads is starting to get out of hand. We currently have the following names for threads:
[repl writer worker-#]
These names are not very descriptive, other than the "writer worker" names. While they don't necessarily need to explain exactly what is going on, it would be helpful if the names were chosen to be less generic and more easily searched-for in the code.