Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-36456

MongoD does not support kerberos on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 4.0.0
    • Fix Version/s: 4.0.3, 4.1.4
    • Component/s: Security
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Backport Requested:
      v4.0
    • Sprint:
      Security 2018-09-10, Security 2018-09-24

      Description

      Using the tutorial, MongoD when running on Windows does not support Kerberos authentication (i.e. GSSAPI).

      The issue is that in SERVER-30491, MongoDB's custom auxprop was removed. This broke support for kerberos since mongod calls canon_user which now always fails since there is no auxprop plugin.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: