-
Type:
Improvement
-
Resolution: Won't Fix
-
Priority:
Major - P3
-
None
-
Affects Version/s: None
-
Component/s: Usability
-
None
-
Fully Compatible
When a command fails, the response object currently contains various combinations of the following fields:
'err'
'errmsg'
'assertion'
'code'
'assertionCode'
For example, see the return value for:
db.runCommand(
)
This is a bit awkward from a client perspective. Can we normalize on 'err' and 'code'? If the different fields indicate different kinds of errors, we should specify that in yet another field, e.g., 'errorType'.