Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-37736

Unify the naming for RecordId variables

    • Type: Icon: Improvement Improvement
    • Resolution: Won't Fix
    • Priority: Icon: Major - P3 Major - P3
    • None
    • Affects Version/s: None
    • Component/s: Storage
    • Labels:
      None
    • Storage Execution

      We used "loc", "rid", and "id" interchangeably for RecordId variables in the codebase. We should unify them to improve code readability.

      It seemed we once had a try in SERVER-20549, but only for WiredTiger.

      "loc" probably only makes sense for MMapV1.

            Assignee:
            backlog-server-execution [DO NOT USE] Backlog - Storage Execution Team
            Reporter:
            xiangyu.yao@mongodb.com Xiangyu Yao (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Created:
              Updated:
              Resolved: